const regex = new RegExp('旅行名稱:(?P<TourName>.*?),價錢:(?P<Price>[\\d,]+),日期:\\d{4}/\\d{2}/\\d{2}</p>', 'gm')
const str = `<p>旅行名稱:去韓國玩,價錢:5,000,日期:2018/03/20</p><p>旅行名稱:去日本玩,價錢:8,000,日期:2018/07/15</p>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}