use strict;
my $str = '<p>旅行名稱:去韓國玩,價錢:5,000,日期:2018/03/20</p><p>旅行名稱:去日本玩,價錢:8,000,日期:2018/07/15</p>';
my $regex = qr/旅行名稱:(?P<TourName>.*?),價錢:(?P<Price>[\d,]+),日期:\d{4}/\d{2}/\d{2}</p>/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}