import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*?(\\d{1,3}((.\\d{1,3}){3})).*";
final String string = "1.ibvpn.com 212.199.114.139 \n"
+ "2) il2.ibvpn.com 185.229.226.251 \n"
+ "1) hk1.ibvpn.com 103.53.199.63 \n"
+ "3) hk3.ibvpn.com 27.0.232.223 \n"
+ "1) jp1.ibvpn.com 13.114.225.40 \n"
+ "2) jp2.ibvpn.com 103.75.118.117 \n"
+ "3) jp3.ibvpn.com 45.32.29.235 \n"
+ "4) jp4.ibvpn.com 91.207.174.190 \n"
+ "1) tr1.ibvpn.com 185.65.206.153 ";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}