# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r".*?(\d{1,3}((.\d{1,3}){3})).*"
test_str = ("1.ibvpn.com 212.199.114.139 \n"
"2) il2.ibvpn.com 185.229.226.251 \n"
"1) hk1.ibvpn.com 103.53.199.63 \n"
"3) hk3.ibvpn.com 27.0.232.223 \n"
"1) jp1.ibvpn.com 13.114.225.40 \n"
"2) jp2.ibvpn.com 103.75.118.117 \n"
"3) jp3.ibvpn.com 45.32.29.235 \n"
"4) jp4.ibvpn.com 91.207.174.190 \n"
"1) tr1.ibvpn.com 185.65.206.153 ")
subst = "$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.