// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r".*?(\d{1,3}((.\d{1,3}){3})).*").unwrap();
let string = "1.ibvpn.com 212.199.114.139
2) il2.ibvpn.com 185.229.226.251
1) hk1.ibvpn.com 103.53.199.63
3) hk3.ibvpn.com 27.0.232.223
1) jp1.ibvpn.com 13.114.225.40
2) jp2.ibvpn.com 103.75.118.117
3) jp3.ibvpn.com 45.32.29.235
4) jp4.ibvpn.com 91.207.174.190
1) tr1.ibvpn.com 185.65.206.153 ";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}