import Foundation
let pattern = #".*?(\d{1,3}((.\d{1,3}){3})).*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
1.ibvpn.com 212.199.114.139
2) il2.ibvpn.com 185.229.226.251
1) hk1.ibvpn.com 103.53.199.63
3) hk3.ibvpn.com 27.0.232.223
1) jp1.ibvpn.com 13.114.225.40
2) jp2.ibvpn.com 103.75.118.117
3) jp3.ibvpn.com 45.32.29.235
4) jp4.ibvpn.com 91.207.174.190
1) tr1.ibvpn.com 185.65.206.153
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)