const regex = /(Q[^a-zA-Z ]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(Q[^a-zA-Z ]+)', 'gm')
const str = `Fellowes Folders, Blue
SanDisk Numeric Keypad, Bluetooth
Avery Legal,Q3-2024 Exhibit Labels, 5000 Label Set
Fellowes Folders, Wire Frame
Memorex Memory Card, USB
Rogers Shelving, Wire Frame
Apple Signal Q2/24 Booster, Full Size
Canon Personal Copier, Laser
Hoover Stove, Red
Accos Push Pins, Bulk Pack
Hon Color Coded Labels, Alphabetical
Hamilton Beach Stove, Silver
Binney & Q1-23 Smith Pens, Easy-Erase
Samsung Smart Phone, Full Size
Rogers Folders, Blue
Smead Trays, Wire Frame
Belkin Memory Card, USB
Hon Removable Labels, Adjustable
GlobeWeis Peel and Seal, Set of 50`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}