# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(Q[^a-zA-Z ]+)"
test_str = ("Fellowes Folders, Blue\n"
"SanDisk Numeric Keypad, Bluetooth\n"
"Avery Legal,Q3-2024 Exhibit Labels, 5000 Label Set\n"
"Fellowes Folders, Wire Frame\n"
"Memorex Memory Card, USB\n"
"Rogers Shelving, Wire Frame\n"
"Apple Signal Q2/24 Booster, Full Size\n"
"Canon Personal Copier, Laser\n"
"Hoover Stove, Red\n"
"Accos Push Pins, Bulk Pack\n"
"Hon Color Coded Labels, Alphabetical\n"
"Hamilton Beach Stove, Silver\n"
"Binney & Q1-23 Smith Pens, Easy-Erase\n"
"Samsung Smart Phone, Full Size\n"
"Rogers Folders, Blue\n"
"Smead Trays, Wire Frame\n"
"Belkin Memory Card, USB\n"
"Hon Removable Labels, Adjustable\n"
"GlobeWeis Peel and Seal, Set of 50")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.