// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(Q[^a-zA-Z ]+)").unwrap();
let string = "Fellowes Folders, Blue
SanDisk Numeric Keypad, Bluetooth
Avery Legal,Q3-2024 Exhibit Labels, 5000 Label Set
Fellowes Folders, Wire Frame
Memorex Memory Card, USB
Rogers Shelving, Wire Frame
Apple Signal Q2/24 Booster, Full Size
Canon Personal Copier, Laser
Hoover Stove, Red
Accos Push Pins, Bulk Pack
Hon Color Coded Labels, Alphabetical
Hamilton Beach Stove, Silver
Binney & Q1-23 Smith Pens, Easy-Erase
Samsung Smart Phone, Full Size
Rogers Folders, Blue
Smead Trays, Wire Frame
Belkin Memory Card, USB
Hon Removable Labels, Adjustable
GlobeWeis Peel and Seal, Set of 50";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}