#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)https?:\/\/(?:[\w-]+\.api-platform\.com|localhost(?::\d+)?)"
Local $sString = "http://localhost" & @CRLF & _
"http://localhost:3000" & @CRLF & _
"http://api-platform.com" & @CRLF & _
"https://www.api-platform.com" & @CRLF & _
"https://fakeapi-platform.com/ #oops!"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")