const regex = /https?:\/\/(?:[\w-]+\.api-platform\.com|localhost(?::\d+)?)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('https?:\\\/\\\/(?:[\\w-]+\\.api-platform\\.com|localhost(?::\\d+)?)', 'gm')
const str = `http://localhost
http://localhost:3000
http://api-platform.com
https://www.api-platform.com
https://fakeapi-platform.com/ #oops!`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}