import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "https?:\\/\\/(?:[\\w-]+\\.api-platform\\.com|localhost(?::\\d+)?)";
final String string = "http://localhost\n"
+ "http://localhost:3000\n"
+ "http://api-platform.com\n"
+ "https://www.api-platform.com\n"
+ "https://fakeapi-platform.com/ #oops!";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}