$re = '/https?:\/\/(?:[\w-]+\.api-platform\.com|localhost(?::\d+)?)/m';
$str = 'http://localhost
http://localhost:3000
http://api-platform.com
https://www.api-platform.com
https://fakeapi-platform.com/ #oops!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);