package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?xm)^
(?!.*\b(\d+)\b.*\b\1\b)
(0?\d|[12][0-9]|3[01])
(,(0?\d|[12][0-9]|3[01]))*
$`)
var str = `2,4,6,7,1
2,2,6
2
2,
1,2,3,4,15,6,7,31
1,2,3,4,15,6,7,32
20,15,3`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}