use strict;
my $str = '2,4,6,7,1
2,2,6
2
2,
1,2,3,4,15,6,7,31
1,2,3,4,15,6,7,32
20,15,3';
my $regex = qr/^
(?!.*\b(\d+)\b.*\b\1\b)
(0?\d|[12][0-9]|3[01])
(,(0?\d|[12][0-9]|3[01]))*
$/xmp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}