$re = '/^
(?!.*\b(\d+)\b.*\b\1\b)
(0?\d|[12][0-9]|3[01])
(,(0?\d|[12][0-9]|3[01]))*
$/xm';
$str = '2,4,6,7,1
2,2,6
2
2,
1,2,3,4,15,6,7,31
1,2,3,4,15,6,7,32
20,15,3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);