use strict;
my $str = '8 fg
e8riééééééé
a gi- d d\'alroe
érien4
f kr
04b
n44
k kl *+
adrien
d\'Al Meida
';
my $regex = qr/^[A-Za-zÀ-ÖØ-ö_ø-ÿ][\wÀ-ÖØ-ö_ø-ÿ \.\'\-]*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}