import re
regex = re.compile(r"^[A-Za-zÀ-ÖØ-ö_ø-ÿ][\wÀ-ÖØ-ö_ø-ÿ \.\'\-]*$", flags=re.MULTILINE)
test_str = ("8 fg\n"
"e8riééééééé\n"
"a gi- d d'alroe\n"
"érien4\n"
"f kr\n"
"04b\n"
"n44\n"
"k kl *+\n"
"adrien\n"
"d'Al Meida\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")