re = /^[A-Za-zÀ-ÖØ-ö_ø-ÿ][\wÀ-ÖØ-ö_ø-ÿ \.\'\-]*$/m
str = '8 fg
e8riééééééé
a gi- d d\'alroe
érien4
f kr
04b
n44
k kl *+
adrien
d\'Al Meida
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end