// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[A-Za-zÀ-ÖØ-ö_ø-ÿ][\wÀ-ÖØ-ö_ø-ÿ \.\'\-]*$").unwrap();
let string = "8 fg
e8riééééééé
a gi- d d'alroe
érien4
f kr
04b
n44
k kl *+
adrien
d'Al Meida
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}