#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\d+\.\d+\.\d+_\d+-\d+"
Local $sString = "'/gauguin/twrp-3.5.2_10-0-gauguin.img.html'," & @CRLF & _
"'/gauguin/twrp-3.5.1_10-0-gauguin.img.html'," & @CRLF & _
"'/gauguin/twrp-3.5.0_10-0-gauguin.img.html'"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")