$re = '/\d+\.\d+\.\d+_\d+-\d+/m';
$str = '\'/gauguin/twrp-3.5.2_10-0-gauguin.img.html\',
\'/gauguin/twrp-3.5.1_10-0-gauguin.img.html\',
\'/gauguin/twrp-3.5.0_10-0-gauguin.img.html\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);