import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d+\\.\\d+\\.\\d+_\\d+-\\d+";
final String string = "'/gauguin/twrp-3.5.2_10-0-gauguin.img.html',\n"
+ "'/gauguin/twrp-3.5.1_10-0-gauguin.img.html',\n"
+ "'/gauguin/twrp-3.5.0_10-0-gauguin.img.html'";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}