package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\d+\.\d+\.\d+_\d+-\d+`)
var str = `'/gauguin/twrp-3.5.2_10-0-gauguin.img.html',
'/gauguin/twrp-3.5.1_10-0-gauguin.img.html',
'/gauguin/twrp-3.5.0_10-0-gauguin.img.html'`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}