# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?s)(?<=<Building \\/>).*(?=<\\/Building>)//gm;t' <<< "<Building />
floor
</Building>"