re = /(?s)(?<=<Building \/>).*(?=<\/Building>)/m
str = '<Building />
floor
</Building>'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result