$re = '/(?s)(?<=<Building \/>).*(?=<\/Building>)/m';
$str = '<Building />
floor
</Building>';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;