use strict;
my $str = '<Building />
floor
</Building>';
my $regex = qr/(?s)(?<=<Building \/>).*(?=<\/Building>)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";