#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[0-9]{1,3}[abAB]?$"
Local $sString = "1abbbaa434" & @CRLF & _
"25" & @CRLF & _
"15a" & @CRLF & _
"45B" & @CRLF & _
"2A" & @CRLF & _
"53b" & @CRLF & _
"96" & @CRLF & _
"" & @CRLF & _
"A" & @CRLF & _
"a" & @CRLF & _
"B" & @CRLF & _
"b" & @CRLF & _
"B76" & @CRLF & _
"a34"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")