$re = '/^[0-9]{1,3}[abAB]?$/m';
$str = '1abbbaa434
25
15a
45B
2A
53b
96
A
a
B
b
B76
a34';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);