re = /^[0-9]{1,3}[abAB]?$/m
str = '1abbbaa434
25
15a
45B
2A
53b
96
A
a
B
b
B76
a34'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end