package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[0-9]{1,3}[abAB]?$`)
var str = `1abbbaa434
25
15a
45B
2A
53b
96
A
a
B
b
B76
a34`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}