# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([0-9]{4}-[0-9]{2}-[0-9]{2} [0-9]{2}:[0-9]{2}:[0-9]{2}) \(([^)]*).*\[([0-9]+)/DateTime: $1, Speed: $2, Size: $3/gm;t' <<< "2022-12-26 19:14:44 (13.7 Mb/s) - ‘somelibrary.min.js’ saved [1077022]"