use strict;
my $str = '2022-12-26 19:14:44 (13.7 Mb/s) - ‘somelibrary.min.js’ saved [1077022]';
my $regex = qr/([0-9]{4}-[0-9]{2}-[0-9]{2} [0-9]{2}:[0-9]{2}:[0-9]{2}) \(([^)]*).*\[([0-9]+)/mp;
my $subst = 'DateTime: $1, Speed: $2, Size: $3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";