$re = '/([0-9]{4}-[0-9]{2}-[0-9]{2} [0-9]{2}:[0-9]{2}:[0-9]{2}) \(([^)]*).*\[([0-9]+)/m';
$str = '2022-12-26 19:14:44 (13.7 Mb/s) - ‘somelibrary.min.js’ saved [1077022]';
$subst = "DateTime: $1, Speed: $2, Size: $3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;