import re
regex = re.compile(r"([0-9]{4}-[0-9]{2}-[0-9]{2} [0-9]{2}:[0-9]{2}:[0-9]{2}) \(([^)]*).*\[([0-9]+)", flags=re.MULTILINE)
test_str = "2022-12-26 19:14:44 (13.7 Mb/s) - ‘somelibrary.min.js’ saved [1077022]"
subst = "DateTime: $1, Speed: $2, Size: $3"
result = regex.sub(subst, test_str)
if result:
print(result)