import re
regex = re.compile(r"(?:[\(])*([\d]{3,3})(?:[\)\.\ ])*([\d]{3,3})(?:[\-\.])*([\d]{4,4})")
test_str = ("586.943.9341\n"
"5869439241\n"
"(586)123-4567\n"
"(586) 943-9341")
subst = "$1-$2-$3"
result = regex.sub(subst, test_str)
if result:
print(result)