# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\d+\.\d{5})\d*/$1/g;t' <<< "-103.3751447563353"