$re = '/(\d+\.\d{5})\d*/';
$str = '-103.3751447563353';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;