use strict;
my $str = '-103.3751447563353';
my $regex = qr/(\d+\.\d{5})\d*/p;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";