$re = '/^[1-9]\d\d?(?:,[1-9]\d\d?)*$/m';
$str = '12,123,56,567,789,11
1,23,456
025,123,456
1234,56,78
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);