package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m) (SessionID=".*?")?(?: .*(MsgType=".*?"))? `)
var str = `2021-10-07 10:32:05,767 ERROR [LAWT2] blah.blah.blah - Message processing FAILED: <ExecutionReport blah="xxx" foo="yyy" SessionID="kkk" MoreStuff="zz"> Total time for which application threads were stopped: 0.0003858 seconds, Stopping threads took: 0.0000653 seconds
2021-10-07 10:31:32,902 ERROR [LAWT6] blah.blah.blah - Message processing FAILED: <NewOrderSingle SessionID="zkx" TargetSubID="ttt" Account="blah" MsgType="D" BookingTypeOverride="0" Symbol="6316" OtherField1="othervalue1" Otherfield2="othervalue2"/></D></NewOrderSingle>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}