import re
regex = re.compile(r" (SessionID=\".*?\")?(?: .*(MsgType=\".*?\"))? ", flags=re.MULTILINE)
test_str = ("2021-10-07 10:32:05,767 ERROR [LAWT2] blah.blah.blah - Message processing FAILED: <ExecutionReport blah=\"xxx\" foo=\"yyy\" SessionID=\"kkk\" MoreStuff=\"zz\"> Total time for which application threads were stopped: 0.0003858 seconds, Stopping threads took: 0.0000653 seconds\n"
"2021-10-07 10:31:32,902 ERROR [LAWT6] blah.blah.blah - Message processing FAILED: <NewOrderSingle SessionID=\"zkx\" TargetSubID=\"ttt\" Account=\"blah\" MsgType=\"D\" BookingTypeOverride=\"0\" Symbol=\"6316\" OtherField1=\"othervalue1\" Otherfield2=\"othervalue2\"/></D></NewOrderSingle>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")