// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m) (SessionID=".*?")?(?: .*(MsgType=".*?"))? "#).unwrap();
let string = "2021-10-07 10:32:05,767 ERROR [LAWT2] blah.blah.blah - Message processing FAILED: <ExecutionReport blah=\"xxx\" foo=\"yyy\" SessionID=\"kkk\" MoreStuff=\"zz\"> Total time for which application threads were stopped: 0.0003858 seconds, Stopping threads took: 0.0000653 seconds
2021-10-07 10:31:32,902 ERROR [LAWT6] blah.blah.blah - Message processing FAILED: <NewOrderSingle SessionID=\"zkx\" TargetSubID=\"ttt\" Account=\"blah\" MsgType=\"D\" BookingTypeOverride=\"0\" Symbol=\"6316\" OtherField1=\"othervalue1\" Otherfield2=\"othervalue2\"/></D></NewOrderSingle>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}