using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!#)[^:]*:";
string input = @"ping-command-output: <green>%s's ping is %sms
rambar-command-output: <green>Rambar toggled <onoff> for <target>
tpsbar-command-output: <green>Tpsbar toggled <onoff> for <target>
ram-command-output: '<green>Ram Usage: <used>/<xmx> (<percent>)'";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}