$re = '/^(?!#)[^:]*:/m';
$str = 'ping-command-output: <green>%s\'s ping is %sms
rambar-command-output: <green>Rambar toggled <onoff> for <target>
tpsbar-command-output: <green>Tpsbar toggled <onoff> for <target>
ram-command-output: \'<green>Ram Usage: <used>/<xmx> (<percent>)\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);