re = /^(?!#)[^:]*:/m
str = 'ping-command-output: <green>%s\'s ping is %sms
rambar-command-output: <green>Rambar toggled <onoff> for <target>
tpsbar-command-output: <green>Tpsbar toggled <onoff> for <target>
ram-command-output: \'<green>Ram Usage: <used>/<xmx> (<percent>)\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end