import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!#)[^:]*:";
final String string = "ping-command-output: <green>%s's ping is %sms\n"
+ "rambar-command-output: <green>Rambar toggled <onoff> for <target>\n"
+ "tpsbar-command-output: <green>Tpsbar toggled <onoff> for <target>\n"
+ "ram-command-output: '<green>Ram Usage: <used>/<xmx> (<percent>)'";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}