import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "src='(.+?)' type=\"video/mp4\" data-res=\"(.+?)\" />";
final String string = "<video id=\"cb_video_js\" class=\"video-js vjs-default-skin\" width=\"320px\" height=\"240px\" poster=\"http://192.168.0.116/files/thumbs/High.Res.02/1507360901c8cef-1.jpg\" >\n"
+ "<source src='http://192.168.0.116/files/videos/High.Res.02/1507360901c8cef-480.mp4' type=\"video/mp4\" data-res=\"480\" />\n"
+ "<source src='http://192.168.0.116/files/videos/High.Res.02/1507360901c8cef-720.mp4' type=\"video/mp4\" data-res=\"720\" />\n"
+ "<p class=\"vjs-no-js\">To view this video please enable JavaScript, and consider upgrading to a web browser that <a href=\"http://videojs.com/html5-video-support/\" target=\"_blank\">supports HTML5 video</a></p>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}