$re = '/src=\'(.+?)\' type="video/mp4" data-res="(.+?)" />/';
$str = '<video id="cb_video_js" class="video-js vjs-default-skin" width="320px" height="240px" poster="http://192.168.0.116/files/thumbs/High.Res.02/1507360901c8cef-1.jpg" >
<source src=\'http://192.168.0.116/files/videos/High.Res.02/1507360901c8cef-480.mp4\' type="video/mp4" data-res="480" />
<source src=\'http://192.168.0.116/files/videos/High.Res.02/1507360901c8cef-720.mp4\' type="video/mp4" data-res="720" />
<p class="vjs-no-js">To view this video please enable JavaScript, and consider upgrading to a web browser that <a href="http://videojs.com/html5-video-support/" target="_blank">supports HTML5 video</a></p>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);